EU - UK packetlosss
Incident Report for HiperZ
Resolved
This incident has been resolved.
Posted 2 months ago. Feb 03, 2019 - 22:15 UTC
Investigating
EU - UK is currently experiencing packetloss
Posted 2 months ago. Feb 03, 2019 - 22:02 UTC
This incident affected: Gameservers EU (UK).