Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 20, 2025 - 16:00 UTC
Scheduled
NA - US - New York will be undergoing emergency power maintenance within the scheduled window. Workload in the location will be temporarily unavailable during the power distribution maintenance within each of the affected racks
Posted Oct 19, 2025 - 13:10 UTC
This scheduled maintenance affected: Gameservers NA (USA - New York).