·
Resolved
Monitoring
A fix has been implemented - monitoring
Investigating
EU - UK - network reachability issues