TS3 EU network issues
Incident Report for HiperZ
Resolved
This incident has been resolved.
Posted Jul 10, 2018 - 10:23 UTC
Update
Due to a routing problem, the systems are currently not reachable.
Posted Jul 10, 2018 - 10:17 UTC
Investigating
We are currently investigating this issue.
Posted Jul 10, 2018 - 10:00 UTC
This incident affected: Teamspeak (TeamSpeak EU).