www.hiperz.com - maintenance
Incident Report for HiperZ
Resolved
This incident has been resolved.
Posted Jul 11, 2018 - 11:07 UTC
Identified
Maintenance part #2 on the website and support ticketing system backend
Posted Jul 11, 2018 - 07:55 UTC
This incident affected: Services (www.hiperz.com).