hiperz.com website maintenance
Incident Report for HiperZ
Resolved
2nd part of the maintenance completed, ordering and ticketing fully back online
Posted 2 months ago. Apr 09, 2019 - 09:30 UTC
Update
first set of maintenance work has been completed, we have now another set of works to do that will result in outage again
Posted 2 months ago. Apr 09, 2019 - 08:19 UTC
Identified
maintenance is still ongoing, sorry for the troubles
Posted 2 months ago. Apr 09, 2019 - 07:54 UTC
Investigating
hiperz.com website maintenance - ticketing and ordering systems are affected while we performe maintenance.

you can still use emails to contact us about support requests
Posted 2 months ago. Apr 09, 2019 - 07:07 UTC
This incident affected: Services (www.hiperz.com).